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Introduction  
 
GC-Prevue is GraphiCode’s industry leading Gerber viewer. PCB designers, fabricators, OEMs, 
and contract manufacturers use it worldwide. It has provided outstanding value for literally 
hundreds of thousands of users since its initial release over 10 years ago. Much copied, but 
never bettered, GC-Prevue is still the tool of choice for viewing Gerber. 
 
In response to many enquiries from GC-Prevue users, GraphiCode has added simple editing 
tools, enhanced measurement tools, and outputs to GC-Prevue to create GC-PrevuePlus. 
Borrowing tried and tested functionality from our CAM product (GC-PowerStation), GC-
PrevuePlus now allows you to make changes to the Gerber data, output updated information, 
convert from Gerber to Extended Gerber, import Autocad DXF/DWG files, and make major or 
minor changes to your data. 
 
You will discover as you navigate through the demonstration guide that both GC-Prevue and GC-
PrevuePlus save you time and money. The software allows you to view many different flavors of 
Gerber, catch and fix errors in the data, and translate customer data into more useful formats. 
 
If you have any questions at any time throughout this demo, please call your authorized 
GraphiCode reseller. If you have obtained this Demonstration Guide from GraphiCode directly, 
please call 425-672-1980 or email us at sales@graphicode.com. 
 

Recommended System Configuration 
This demonstration guide assumes users have a working knowledge of MS Windows. 
 
400 MHz Pentium or equivalent preferred 
Windows XP, 2000, NT (4.x), 95 or 98: NT or 2000 preferred 
64 MB RAM min. 256 MB preferred  
2 GB+ hard disk 
Windows accelerator video card with 2MB or more video DRAM 
17” or larger monitor, 800x600 or greater resolution 
 

Symbols and Hints to using the Guide 
 
This symbol  > represents “find and select”. 
All menu options are displayed in Bold Italics 
Example: Choose File > Import means choose File from the main menu then select Import. 
 

Files required for using the Guide 
 
General Navigation.GWK  Aperture.rep 
Silkbot.gbr:     Silktop.gbr 
Bottomside.gbx    Topside.gbx 
GC-conv-aper.zxz   Bottom mask.gbr 
Top mask.gbr    Ncdrill.drl 



Use the Tools > 
Customize > File 
Locations tab to set 
the default path for 
Job Files 

Chapter 1: Basic Navigation 

Loading a GWK 
All GraphiCode products (GC-PowerPlace with Test, GC-PowerPlace, GC-PowerStation, GC-
CAM Edit, GC-PrevuePlus and GC-Prevue) save data in the GWK file format. This file format is 
backwards compatible and allows information to be easily transferred. A GWK file can contain 
printed circuit board layers, names, aperture lists, drill lists, BOM, editing changes, and feature 
settings. For this first lesson we have already loaded the raw Gerber data files for you and saved 
the information in a GWK file – later lessons will deal with loading many different types of Gerber 
and Drill information.  
 
We will now spend a little time learning the major areas of the software by loading a GWK file and 
performing some simple tasks. 
 

1. Start GC-Prevue or GC-PrevuePlus 
2. From the main menu choose File > Open 
3. Use the file picker to navigate to the directory where you uncompressed the zipped 

demonstration guide. 
4. Select the General Navigation.GWK then select Open 

 
A graphical representation of the physical board appears on screen (see Figure 1).  
 

   

Figure 1: Loaded Data 

Saving 
Any changes made to the GWK can be saved by selecting File > Save (to save an updated 
version of the current file) or by using File > Save As… (to rename the updated file). 

Navigation – Zoom 
On many occasions, you will want to enlarge or reduce an area of the board for better viewing. 
Let’s experiment with the zoom features of GC-Prevue or GC-PrevuePlus. 
 

1. Figure 1 highlights Navigation view. This window gives a bird’s eye view of the current 
graphical display with reference to the data extents. 

2. Click on the Maximize button to maximize the current graphical window. Note how the 
Navigation View updates. 

3. Click the right mouse button to obtain a list of options and choose Zoom to Extents (see 
Figure 2). 

Navigation View 

  
Minimize/Maximize/Close 

GC-Explorer 



        

Figure 2: Right mouse button menu 

4. The displayed data is then automatically fitted within the current graphical window. 
Zooming to Extents will always display the current visible data within the window at the 
lowest zoom level. 

5. To zoom in, drag a window with your left mouse button around the area you wish to 
investigate. You will then see a pop-up menu that allows you to Zoom In. (The Zoom to 
Window option creates a new window at the new zoom and is best seen when graphical 
windows are not maximized). 

6. To zoom out, click the right mouse button and select the Zoom Out option. 
7. To zoom to the previous zoom level, click the right mouse button and select the Zoom 

Previous option. 
8. If your mouse has a mouse wheel, rolling the mouse wheel away from you will zoom in 

and towards you to zoom out. 
9. Continue to experiment with the zoom features. Note: For users of GC-Prevue v8.x or 

earlier you can still double right click to zoom out if you change the setting in Tools > 
Customize > Edit dialog. 

10.  All Zoom features can also be located under View > Zoom along with current hotkey 
settings. 

11.  When you are finished exploring, choose Zoom Extents to mirror Figure 3 
 

 

Figure 3: Zoom Extents 

GC-Explorer 
The GC-Explorer window contains information about all layers in the GWK file. Layers are divided 
into three distinct types. 

 
1. Holes/Routs – These layers represent any drill holes or rout path information 
2. Physical Layers – These layers represent the physical layers of the board and have a 

layer type definition. Physical layers can consist of one or many data layers allowing the 
combination of positive data and negative ‘scratch’ data within a single layer. 

3. Unassigned layers – These layers are all remaining layers either not assigned as 
Physical Layers or layers not necessary to prepare an assembly program.  

 



The properties for any layer can be viewed by double clicking the layer in the GC-Explorer 
window. They can also be viewed by selecting the layer with the left mouse button and clicking 
the right mouse button and selecting Properties. 
 

1. Select the Physical Layer P2 “Comp” top with the left mouse button 
2. Click the right mouse button and select Properties. 
3. The Properties tab is displayed 
4. You can see that the properties for a Physical Layer include such attributes as Layer 

Name, Layer Type, Side, Layer Colors, and Visibility. Feel free to change some of the 
properties, select Apply and note their effect in the GC-Explorer window.  

5. The GC-Explorer list in the left pane of the dialog allows other layers to be selected and 
changed as required. 

6. Select OK to come out of the GC-Explorer dialog. 

View/Hide/Edit 
One attribute that is very useful to change is the Visibility Status of a layer. Layers can be edit-
enabled (edit), hidden (hide) or visible (view). These different settings provide security by 
enabling you to only change layers that are edit enabled. If a layer’s status is set to view or hide, 
data on that layer cannot be edited.  
 

1. Select View > Layers > Hide All. You will see all data disappear from the graphical 
window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

2. Now we will set Physical layer P2 to Edit status in preparation for editing. Select the 
Physical layer P2 using the left mouse button and then use the right mouse button to give 
the drop down menu and then select Edit. You will now see the GC-Explorer name is now 
shown in bold with the (e) attribute indicating Edit enabled status. The graphics screen 
will not refresh until you click back in the graphics window as this allows you to set the 
View/Hide/Edit status of other layers without having to wait for redraws. 

 
You may have noticed that the hotkey for setting a layer’s status to edit-enabled was E (V for 
View and H for Hide) so now try experimenting by selecting a layer in the GC-Explorer and using 
the hotkey to rapidly set layer visibility.  
 

3. Also try setting layer visibility when the Physical Layers branch is selected (as shown in 
Figure 4). You will notice that the change applies to the parent and the children (see 
Figure 5).  

 

             

Figure 4: Highlighting the Parent  Figure 5: All Physical layers in Edit            

4. After gaining a better understanding of how Hide/View/Edit status is controlled, Select 
View > Layers > Hide All to hide all layers and then make Physical layer P2 Editable by 
selecting that layer and hitting the Hotkey ‘E’. 

 
 

 

Selecting Data 
 



Use the Tools > 
Customize > Edit tab 
to turn off left mouse 
button selection if you 
prefer 

Many functions within GC-Prevue or GC-PrevuePlus work with data that has been selected. This 
allows certain features on a layer to be worked upon without affecting the other data on the layer. 
Selection of data can only occur on a layer that has edit-enabled status set. 
We will now investigate some methods of selecting data – based on having all layers in the Hide 
mode EXCEPT for P2, which is in Edit mode. 
 

1. Choose Edit > Select All. The data should turn White indicating that the data is selected. 
Note also that the Co-ordinate Summary Window indicates the number of Pads and Drills 
and Routs and Traces selected (see Figure 6). This is always a useful place to check to 
ensure that data is not unintentionally selected. 

 
 

Figure 6: Co-ordinate summary 
 
2. Zoom in on a selected area (see the preceding section for how to zoom in) and we will 

look at unselecting and reselecting data. Ensure that a number of entities (pads and 
traces) appear large enough on screen so that it is clear when the crosshair is positioned 
over an entity. 

3. Now use the Left mouse button to deselect a currently selected entity. You can reselect 
the feature by using the left mouse button. The left mouse button toggles the selection of 
data in an edit-enabled state. 

4. Holding down the Control button while selecting with the 
left mouse button will deselect all data prior to selecting 
the entity under the cursor. This is a quick method of 
ensuring that the selected data is the only entity selected.  

5. To select an area, drag a box with the left mouse button 
and either choose the option Select Touching or Select 
Inside. The Select Touching option will select data that is both completely or partially 
within the box. The Select Inside option will select data that is completely within the box. 
The same also applies to the Unselect Touching and Unselect Inside options.  



6. After experimenting with the above methods of selecting, choose Edit > Unselect All. 
You should have zero values in the Co-ordinates Summary window for selected data. 

7. Now move your cursor over an entity and click the right mouse button. Choose the Select 
this Tool function. A tool simply refers to an entry in an aperture or drill table. Any 
occurrence of this tool should be selected. (If this is not the case make sure that the 
cursor and the crosshair are joined by hitting the space bar). 

 

      

Figure 7: Select This Tool - Before   Figure 8: Select This Tool – After 

 
8. The Unselect this Tool function can be used in the same manner. 
9. The Edit > Select > Filter Selection option also allows for entities to be selected or 

unselected based on size, shape, D-Code. 
10.  When you are happy with the idea of selecting and unselecting data choose Edit > 

Unselect All. 

Query and Status Bar 
It is often useful to know some of the information about an entity such as D-Code, size, shape, 
and position as well as reference designator, part number, and package type. GC-Prevue or GC-
PrevuePlus provides that information in a quick and easy-to-understand way. 
 

1. Simply move your crosshair over the entity that you wish to investigate.  
2. View the Status bar along the bottom edge of the application (see Figure 9) to find out 

information about that entity including Layer, Aperture size and Shape, Position, Part 
Number, Reference Designator and other useful information. Note, the information varies 
with the type of entity being investigated (Pad v Trace v Drill v Part) 

 

 

Figure 9: The Status Bar 

3. If multiple items need to be investigated then the Query function can be used. The Query 
function works on selected data so make sure that a number of items are selected.  

4. Select Tools > Query and the Query window will appear (see Figure 10) 
5. The list of selected items is shown along with a graphical window showing the item, the 

navigation view and the Properties of the current item. Pads, Traces, and Parts are 
separated and displayed by making a radio button selection in the bottom left corner. 

6. Features such as Auto Zoom and Zoom In and Zoom Out make changing the graphical 
view straightforward. Auto Zoom makes the transition from viewing large objects to small 
objects easier. 



 

   Figure 10: The Query Window 

 
7. The Properties page can be used to change information associated with the entity. 
8. To close Query select the OK button. 
9. You can now Close this GWK dataset (without saving) in preparation for loading some 

Gerber files and performing edits (if you are using GC-PrevuePlus). Select File > Close 
and select No. 

Properties 
Page 
 
 
 
 
 
 
 
List Control 



Chapter 2: Loading Gerber data 
 

Importing Gerber data 
The dataset that we will use to illustrate many of the features of GC-Prevue or GC-PrevuePlus 
has been adapted to include some RS-274-X files (Extended Gerber), some RS-274-D files, 
some aperture lists that convert automatically, an aperture list that needs manual conversion, and 
some drill data. Gerber data will normally arrive in a consistent format for each job and it is 
important to understand that this dataset is purely meant to illustrate each of the common file 
types you may encounter. 
 

1. From the menu choose File > New 
2. From the menu choose File > Import 
3. The standard Windows file picker dialog appears. Navigate to the directory where you 

uncompressed the zipped demonstration guide. Select the following files using the 
standard Windows selection techniques of using the Control button and/or Shift button: 

 
Aperture.rep: A recognized aperture format 
Silkbot.gbr: Bottom silkscreen Gerber file (uses Aperture.rep) 
Silktop.gbr: Top silkscreen Gerber file (uses Aperture.rep) 
Bottomside.gbx: Bottom Signal Extended Gerber file (apertures embedded in file) 
Topside.gbx: Top Signal Extended Gerber file (apertures embedded in file) 
GC-conv-aper.zxz: Aperture File that requires conversion 
Bottom mask.gbr: Bottom soldermask Gerber file (uses GC-conv-aper.zxz) 
Top mask.gbr: Top soldermask Gerber file (uses GC-conv-aper.zxz) 
Ncdrill.drl: Drill file 

 
4. Hit Select when you have selected the required files. The program now automatically 

recognizes file types and formats. 
5. You will see the Import – Verify File Information dialog. You will notice that all file formats 

except for the GC-conv-aper.zxz file have been reported as successfully recognized. You 
can alter the width of each column by dragging on the column header. 

6. In order to convert this unrecognized aperture format we select from the Drop-down list 
that is accessed through the down arrow in the File Type field (see Figure 11) and 
choose Aperture List. 

 

 

Figure 11: Verify File Information 



 
7. When the format is chosen, the Tool Table Assistant is automatically started, and the file 

is interrogated to see if its format matches an existing format. If the match is successful 
then the conversion is reported in the same way as the Aperture.rep file. If conversion is 
unsuccessful, the Tool Table Assistant is displayed.  

8. The File Type is set to Aperture Table by virtue of your choice from the drop down list. 
Original data type is set to Delimited (some character or whitespace delineates different 
fields). Change the Start Import at row: field to read 5. Select Next. 

9. Enter the values (as shown in Figure 12) to correctly assign different fields to their correct 
value. The delimiter in this case is whitespace (i.e. whitespace separates different fields) 
and the field number for each value can be easily seen. Take care to ensure that units 
are correctly set to inches. 

 

 

Figure 12: Tool Table Assistant 

 
10.  Select Next. 
11.  The next dialog allows the assignment of GraphiCode standard aperture shapes to the 

keywords used in the aperture file. In this case, descriptions are clear and there is 
nothing to change. Select Next. 

12.  The final dialog allows the format information just entered to be memorized and re-used 
on further aperture files of this format (use the Memorize button). For this demonstration 
we will not do this but rather simply select Finish. You are then prompted to save the 
converted file as an external file (can then be re-input at any time without requiring 
conversion). Select No and you will be returned to the File Verify File Information dialog 
but now you will see that the GC-conv-aper.zxz now has a Green Checkmark next to it 
and the 35 tools have been successfully converted. 

13.  GC-PrevuePlus users also have the option to Import DXF and DWG file formats using the 
File Import menu item. Select OK. 

14.  The Assign Tool Tables dialog appears. This dialog is used to assign an aperture table to 
the file that requires it. In this example, we have two aperture lists, each used by two 
Gerber files, two files (the RS-274-X extended Gerber files) which generate their own 
aperture tables and a Drill file (which generates its own Tool table). Again, use the drop 
down box to correctly assign the aperture tables. The files Silktop.gbr and Silkbot.gbr 
need to use the Aperture.Rep file and the Top mask.gbr and Bottom mask.gbr need to 
reference the GC-conv-aper.zxz file. All other layers are fine as they are. See Figure 13. 



 

Figure 13: Aperture Table Assignment 

 
15.  Select OK and the layers will start to load and you will see layers being created in the 

GC-Explorer area. Once loading is completed, you will the File Import Result Dialog. 
16.  There are three tabs: File, Errors, and Tools.  

a. File Tab – Double paned properties page, the right side of which allows you to 
name the layer, set the layer type, change the pad and trace colors for the layer, 
and change other properties of the Physical layer. 

b. Errors Tab – Lists any problems with any of the layers loaded. For example, any 
calls within the Gerber file for an aperture that is not present in the used aperture 
list will be shown in this tab. 

c. Tools Tab – Shows the Aperture Table or Drill Table that is being used by the 
layer being investigated. 

17.  Select OK when you are ready to continue and you will see the loaded Gerber data on 
screen ready for the next section of the demonstration. 

 

Aligning Data 
 
You will notice that the Drill layer is misaligned with the Gerber data. We will now move the Drill 
layer to align with the Gerber files, thus correcting the problem. GC-Prevue allows them 
movement of the entire layer, whereas GC-PrevuePlus allows the movement of individual entities 
or groups of entities. This section of the demonstration guide offsets the entire drill layer.  
 
The layer(s) to be offset must be in Edit mode and must also have data selected. As GC-
PrevuePlus can offset individual features that are selected, we will select the entire layer. GC-
Prevue will offset the entire layer even if only one pad/trace is selected on the layer. 
 

1. Select View > Layers > View All. 
2. Now set the drill layer (H.1) to Edit status in preparation for offsetting it to the Gerber 

data. 
3. Click back in the Graphics Window, right click and Select All. 
4. Move the cursor and crosshair near to a feature that will be the reference point (this will 

be a drill hole that can be aligned to a reference point on one of the other layers). 
5. Use the Jump Nearest feature (located in the Edit Menu - hotkey is "S").  This will jump 

your cursor to the nearest feature.  Then Zero Relative (located in the Tools menu - or 
hotkey "Z").  This sets your Relative Zero coordinates to 0,0. The Relative distance now 
displayed in the Co-ordinate Summary dialog measures the position of the crosshair from 
the zero position. The zero position is the center of the drill hole. If we move our crosshair 
to the center of the pad upon which this drill hole needs to be placed, we will know the 
distance to be moved by reading the Relative Distance in the Co-ordinate Summary 
dialog.  

6. You will notice that the crosshair is now fixed, and only the cursor moves with the mouse.  
Re-attach (carry) the cursor and crosshair by pressing the Space bar. 



7. Move the crosshair and cursor to the corresponding point on the reference layer and 
Jump Nearest to that point. 

8. Select Move To Offset (located in the Edit menu - Hotkey 'O') and the relative distance 
will appear as the default.  Press Enter and the data should move accordingly.  

9. As all the data on the drill layer was selected prior to moving, all data has moved by the 
same amount. NOTE: In GC-PrevuePlus you can select specific entities and move only 
those entities.  

10.  Right click and Unselect All to ensure that all data has been unselected. 

Chapter 3: Editing data (GC-PrevuePlus only) 
 
We will now make measurements, make an amendment to pad shape, delete some data, step 
and repeat data and output an RS-274-X file. GC-PrevuePlus can also perform many other tasks 
regarding the data and we leave it up to you to investigate the other menu items. 
 
For On Line Help simply hover over the menu option and hit F1. 
   
Firstly we will return to the earlier GWK to ensure the images in this demonstration guide are 
consistent. 
 

Measure 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the directory where you uncompressed the zipped 

demonstration guide 
3. Select the General Navigation.GWK then select Open 
4. Select View > Layers > Hide All. You will see all data disappear from the graphical 

window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

5. Now set Physical layer P2 to Edit status in preparation for measuring (although we can 
also measure in View mode), editing and step and repeating. 

6. Zoom in so that you can see a number of objects that you are interested in measuring. 
We will use a row of pads from one of the devices on the board and take measurements 
of separation and of pitch. 

7. In the graphics window, right click and choose the option Switch mode to... and then 
select the Measure option. 

8. You will notice a number of things – the cursor has changed to indicate a different mode 
and also the Co-ordinate Summary has changed in preparation for displaying measured 
values (see Figure 14). 

 



 

      Figure 14: Measuring 

 
9. The order of selecting the entities for measuring is important for the following reasons. 

a. Measurements are given for Edge to Center and Center to Edge. The order of 
selection will affect which is the desired result 

b. Measurement only occurs between two objects. A third object will shuffle the 
previously selected objects down. This is best shown by example. 

10.  Click on an object on screen. You will see the Co-ordinate Summary register one object 
defined. 

11.  Click on a second object and the measurement will be given in the Co-ordinate Summary 
and also graphically. You can change the measurement reported in the Co-ordinate 
Summary window. 

12.  Next, click a third object. You will now see how the objects shuffle down. The last two 
defined objects are now the measured objects. 

13.  The other possibility is that you wish to make multiple measurements from a reference 
point. In this case, select the reference point first and then choose the second measure 
point. Hit Escape and this will remove the second defined object (but retain the reference 
point), leaving you free to define the next measure object.  

14.  Hitting the Escape key twice will remove both defined objects and hitting it a third time 
will return you to the Normal mode. You can also change back to the Normal mode at any 
time by right click, Switch Mode to … Normal. 

 
 
 

Editing Data 
 
Let’s make changes to some of the pads that comprise the device we have been measuring and 
then let’s delete the targets and text box from the layer prior to creating an array. 
 

1. In Normal mode, select a pad or two. They will turn white. Right click while the crosshair 
is over one of the pads and select Properties. The Properties page appears (Figure 15). 

 



 

Figure 15: Properties Page 

 
2. In the properties page you can change the size and shape of the selected pad. If the 

Apply to all button is checked, then the changes made will apply to all identical selected 
pads. (Identical means they share the same aperture (a001.60 in the above figure)). In 
this case let’s make the shape oblong. 

3. A different set of attributes will be presented depending on whether the data under the 
crosshair is a pad, trace, or drill. 

4. When changes have been made, make sure that all data is unselected (right click and 
Unselect All) before moving on. 

 
 

Deleting Data 
 
Deleting unwanted data is very straightforward in GC-PrevuePlus. In order to delete any data 
within GC-PrevuePlus the layer that contains the data to be deleted must be in Edit mode and 
also, the data to be deleted must be selected. Once you have selected the data, go to Edit > 
Delete  and the data is removed.  
 
Deleting data in this way has no affect on the aperture table. 
 
If you prefer to keep a copy of the deleted data around you can use Edit > Cut and Edit > Paste 
to… to move the cut data to its own layer. Tip: When the Paste to… dialog asks you for a layer 
enter U.New and the data will be stored on a new Unassigned layer. 
 
 

Step and Repeat / Panel Array. 
 
A single image (such as we have been looking at) may be arrayed with GC-PrevuePlus. The 
most straightforward array pattern (and the one described below) is an m x n pattern. The array 



function once again applies to selected data. It can therefore be used not only for arraying layers, 
but also for arraying sections of layers, down to a single pad. 
 

1. Select View > Layers > Edit All. You will see all data appear from the graphical window 
and all layers in the GC-Explorer window will now have the (e) status indicating they are 
edit ready. 

2. Highlight layer P16 (the Fabrication drawing) in the GC-Explorer and set its status to 
Hide. We will not array the Fabrication Drawing. 

3. This example will create a 2 x 3 array with a 0.3 inch gap between images in the x plane 
and a 0.5 inch gap in the y plane. The values we will enter can easily be found by 
measuring from the lower left corner of the board to the upper right corner and adding the 
desired gap. 

4. Click into the Graphics window and right click on the mouse. Select Select All and all 
data on screen should turn white. 

5. Select Panel > Array Copy and Paste . 
6. Enter ‘2’ in the X copies 
7. Enter ‘5.675’ inches in the X step 
8. Enter ‘3’ in the Y copies 
9. Enter ‘4.000’ inches in the Y step 
10.  Select OK. 
11.  Right click and Unselect All. 
12.  Right click and Zoom to Extents 

 
The array pattern is now created. The data has been copied to make the array. This means that 
each individual image can be edited if necessary. 
 
More complex array patterns can be created by combining the Array Copy and Paste function, 
the Rotation function and Move to Offset function. If the array copy and paste is performed when 
in Layers (Panelize) mode (see On Line Help for details) the array consists of virtual copies of the 
original – allowing changes made to the original to automatically update the other images in the 
array. 
 

Advanced Scan and Replace 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the Examples directory that is a sub-directory in the 

Installation directory. (For a GC-PrevuePlus v4.4.2 standard installation this would be in 
C:\Program Files\GraphiCode\PowerPlatform 4.4.2\GC-PrevuePlus\Examples). 

3. Select the Loaded.GWK then select Open 
4. Select View > Layers > Hide All. You will see all data disappear from the graphical 

window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

5. Now set Physical layer P3 to Edit status in preparation for converting some of the 
features that look like pads but are constructed using Traces. 

6. Highlight P3 in the GC-Explorer tree, right click and choose Properties. You should 
receive the Properties page for this layer (alternatively you can double click P3). In the 
Properties page you will see two small drop down boxes of color which are grouped 
together – one is the color of Pads, the other is the color of traces. Click the drop down 
box next to pad: to change the color of the pads on the layer. Make sure that the pads 
and the traces are different colors. Click OK and then click in the graphics area. You 
should see that the pads and traces are now displayed in different colors. 

7. The aim of the Advanced Scan and Replace function is the convert a trace or traces into 
a pad. Pads are useful because they are easier to edit in many cases and can be used to 
create other data (for instance the locations of pads can be used to aid in the creation of 
a drill file). 

8. Zoom in to an area that contains a number of SMD pads (note that they should be drawn 
using the Trace color because they are, in fact, not pads but traces. Click on ONE of 



these traces so that it is highlighted (you can verify that it is a trace by using Query or 
Properties if you wish).  

9. Select CAM > Advanced Scan and Replace…. You will see the Advanced Scan and 
Replace dialog appear. This dialog asks for a tolerance to use when converting and the 
required ending pad shape. The tolerance value defaults to zero that means we are going 
to find an exact match to the selected data with no tolerance variation.  A custom pad is 
an exact match to the taught data and can be utilized when none standard pad shapes 
are required. The custom pad requires a name and a unique name is provided based on 
date and time of creation but this is user definable. In most cases (and in this example 
case) it is better to use the simplest pad shape to describe the ending shape. Using 
Rectangle, Round, Oblong etc will result in a pad being created of the exact dimension 
that can then be further edited as necessary.  

10.  In many cases a drill file can be created by creating Round pads from, say, a DXF file 
which has drawn the drill locations using traces.  

11.  Selecting OK will scan the entire layer for the same construction and convert that 
construction to a pad. The changed data is highlighted (we also scan in 0, 90, 180 and 
270 degree orientations to make conversion faster) after conversion. When you right click 
and Unselect All you should see that the features are now the color of the pads.  

12.  Use this function a number of times to become familiar with its operation and be aware 
that whatever data is initially highlighted will form the basis for the searched construction. 
TIP: Sometimes it is better to go to Ball and Stick mode when initially selecting your 
starting construction. 

13.  When you wish to move onto Exporting data please choose File > Open (there is no 
need to save the GWK file) and use the file picker to navigate to the directory where you 
uncompressed the zipped demonstration guide 

14.  Select the General Navigation.GWK then select Open 

Exporting Data 
 
In addition to saving data in the GraphiCode GWK workfile format, GC-PrevuePlus also allows 
the output of RS-274-X, RS-274-D, NC Drill files, basic DXF, HPGL and DPF. We will now simply 
output a couple of RS-274-X (extended Gerber) files to illustrate the ability to translate data with 
GC-PrevuePlus. 
 

1. Select File > Export 
2. Choose the RS-274-X option 
3. The Export dialog appears. 
4. To change the units or precision select the setup tab and make the appropriate changes. 
5. In the Page 1 tab, simply enter the output file name in the Output File field and couple 

this with the layer or layers you wish to output to that file. Continue with other layers in 
the same way. You will also notice that by using the Layer picker, you can select multiple 
layers to be output to the same file. Use the Windows standard methods of Shift or 
Control while selecting with the mouse. 

 
 



 

      Figure 16: Export Dialog 

 
6. You can change the default output file directory by canceling and selecting Tools > 

Customize > File Location tab and modifying the Export Directory. 
7. Continue on to Page 2 etc. if you need to output many files.  
8. Select OK. 

 
 

 
 
 
 
 
Conclusion 
 
This demonstration guide for GC-Prevue or GC-PrevuePlus has only scratched the surface of 
what can be achieved with these tools. Feel free to investigate further on your own and be sure to 
let us have any constructive feedback so that we can continually improve the products. 
 
Thanks for your time 
 
GraphiCode 
(425) 672 1980 
sales@graphicode.com 



Other GraphiCode products 

GC-Services 
GC-Services is more than technical support.  It provides customers with product support, training, 
consulting, and data preparation services. GC-Services provides expertise to elevate employee 
skills, boost manufacturing efficiency, and quickly resolve technical issues. If time or a lack of 
personnel is keeping you from delivering work, GC-Services will do the work for you. 

GC-PowerPlace 
GC-PowerPlace is used by many world-class contract manufacturers and OEMs. PCB assembly 
engineers utilize Gerber data, bill of materials, and/or CAD-XY files to generate pick and place 
programs completely off-line. Centroids are extracted automatically with sub-micron precision so 
accuracy will always be attainable. GC-PowerPlace also creates programs for X-ray inspection 
machines, fluid dispensers, and screen printers. 

GC-PowerStation 
GC-PowerStation serves sophisticated PCB fabricators.  Since 1988, GraphiCode has delivered 
high performance CAM software on the PC and it remains the performance and quality leader on 
the PC platform. GC-PowerStation has all of the features that you expect from a high-end PCB 
CAM system at a fraction of the cost. GC-PowerStation produces data for photoplotters, NC drill 
and rout machines, penplotters and Postscript devices from various data sources. 

GC-CAM Edit 
GC-CAM Edit meets the needs of PCB designers and entry-level CAM operators who require 
convenient design modification capabilities.  Plus it features all the powerful panelization and 
editing tools necessary for PCB photoplotting, drill and routing, stencil manufacturing, and basic 
design modification.  GC-CAM Edit is the low-cost high quality leader for PCB data preparation, 
panelization, and output. 

GC-PrevuePlus 
In response to many inquiries from GC-Prevue users, GraphiCode created GC-PrevuePlus to fill 
the need for an inexpensive Gerber translator and editor. Building on proven functionality from 
GraphiCode's existing family of products, GC-PrevuePlus takes GC-Prevue to the next level.  In 
addition to GC-Prevue’s capabilities, GC-PrevuePlus includes AutoCAD® DXF/DWG import, 
enhanced measurement tools, data editing capabilities and multiple output formats. Users now 
have the answer to verify, translate, edit and convert PCB data files. 

GC-Prevue 
GC-Prevue is GraphiCode’s free data viewer, which is fully compatible with GC-PowerStation, 
GC-PowerPlace, GC-CAM Edit, and GC-PrevuePlus. GC-Prevue gives you the ability to share 
the information within the GraphiCode GWK file with any user at no extra cost. Use it as a tool on 
the shop floor to allow colleagues to quickly identify a component by reference designator or 
location.  
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